upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / klayout / trunk / PKGBUILD
blobfe4902984c3f5696f34917b69f871da61ccaf57a
1 # Contributor: Lars Boettcher <lars@newyew.de>
2 # Maintainer: Aaron Ali <t0nedef@causal.ca>
4 pkgname=klayout
5 pkgver=0.28.7
6 pkgrel=1
7 pkgdesc="High Performance Layout Viewer And Editor. Support of GDS and OASIS files."
8 arch=('x86_64')
9 url="https://www.klayout.de"
10 license=('GPL')
11 depends=('qt5-base' 'qt5-tools' 'qt5-multimedia' 'qt5-xmlpatterns' 'qt5-svg' 'python' 'ruby')
12 source=(http://www.klayout.org/downloads/source/klayout-$pkgver.tar.bz2
13         klayoutEditor.desktop klayoutViewer.desktop)
14 sha512sums=('23d2fd51aee8e9532da8588e46d34963592943a3bf4d0d96cee9d6ed4ad1a3c5c4d92755fb8a7bd6624349f1a0e9fd32be6391cff7fba474ab2cd42dc3cd4ee6'
15             'bc6c7621e5cda754509a86664fb3e7ecd15f577dec712f4b0c52c9a7455ba692043a67145f5bf143d8fdc502b84e4212303906d62107537eefb4bebe57b2ffe1'
16             '37a3bbb06ab155c1c22e3990cf160383570e8ea945dbf4964bc94b6fd4e6321627d31071a29d3dbeafc9e2fc406b6905761e299bfccdfe0a35663f2021624f4f')
18 build() {
19   cd klayout-$pkgver
20   ./build.sh
23 package() {
24   install -D -m 644 klayoutEditor.desktop "$pkgdir"/usr/share/applications/klayoutEditor.desktop
25   install -D -m 644 klayoutViewer.desktop "$pkgdir"/usr/share/applications/klayoutViewer.desktop
26   cd klayout-$pkgver
27   install -D -m 644 etc/logo.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/klayout.png
28   install -D -m 755 build-release/klayout "$pkgdir"/usr/bin/klayout
29   cd bin-release
30   for lib in `find . -type f | grep so`; do
31     install -D -m 755 $lib "$pkgdir"/usr/lib/$lib
32   done
33   for lib in `find . -type l | grep so`; do
34     cp -a $lib "$pkgdir"/usr/lib/$lib
35   done