upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / kube / trunk / PKGBUILD
blobf97ea1407214caf2a681319234a24dd901d32dcb
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kube
4 pkgver=0.9.0
5 pkgrel=2
6 pkgdesc='A modern groupware client based on QtQuick and Sink'
7 arch=(x86_64)
8 url='https://kube.kde.org/'
9 license=(LGPL)
10 depends=(sink gpgme sonnet qt5-quickcontrols2 qt5-webengine qt5-quickcontrols)
11 makedepends=(extra-cmake-modules)
12 #source=(https://download.kde.org/unstable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz)
13 source=(https://invent.kde.org/pim/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
14 sha256sums=('75e6c0d1b04328eb2ada0ceea656753aa1a94361b94feaf81003733470400a63')
16 prepare() {
17   sed -e 's|CMAKE_CXX_STANDARD 20|CMAKE_CXX_STANDARD 17|' -i $pkgname-v$pkgver/CMakeLists.txt # Fix build
18   find . -name CMakeLists.txt | xargs sed -e '/tests/d' -i # Don't build tests
21 build() {
22   cmake -B build -S $pkgname-v$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build