1 # Maintainer: Daniel Bermond <dbermond@archlinux.org>
6 pkgdesc='An open-source HEVC encoder'
8 url='https://github.com/ultravideo/kvazaar/'
11 makedepends=('git' 'yasm')
12 checkdepends=('ffmpeg' 'hm')
13 source=("git+https://github.com/ultravideo/kvazaar.git#tag=v${pkgver}"
14 'git+https://github.com/ultravideo/greatest.git')
19 git -C kvazaar submodule init
20 git -C kvazaar config --local submodule.greatest.url "${srcdir}/greatest"
21 git -C kvazaar -c protocol.file.allow='always' submodule update
22 autoreconf -fi kvazaar
27 ./configure --prefix='/usr' --with-cryptopp
36 make -C kvazaar DESTDIR="$pkgdir" install
37 install -d -m755 "${pkgdir}/usr/share/licenses/kvazaar"
38 mv "${pkgdir}/usr/share/doc/kvazaar"/LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}"