upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / lib32-nss / repos / multilib-x86_64 / PKGBUILD
blob117fb461d56b537f9781b0f39f36f5c057f667c5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
3 # Contributor: kfgz <kfgz at interia pl>
4 # Contributor: Ionut Biru <ibiru at archlinux dot org>
6 pkgname=lib32-nss
7 pkgver=3.89.1
8 pkgrel=1
9 pkgdesc="Network Security Services (32-bit)"
10 url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
11 arch=(x86_64)
12 license=(
13   GPL
14   MPL
16 depends=(
17   'lib32-nspr>=4.35'
18   'lib32-p11-kit>=0.23.19'
19   lib32-sqlite
20   lib32-zlib
21   nss
23 makedepends=(
24   gyp
25   mercurial
26   perl
27   python
29 _revision=c8e02a52aa1979e28bdba814df1b72fc743d66d4
30 source=(
31   "hg+https://hg.mozilla.org/projects/nss#revision=$_revision"
32   0001-Hack-mpi_x64.s-to-work-with-fno-plt.patch
34 b2sums=('SKIP'
35         '733308e0a39d286cba2dc72478f95ca341bb357a8c61aba9dd79681a1210fafc93d8459d5014769f533b54fa987e9e9c5a49437fda5396d42b669d9567919cf4')
37 pkgver() {
38   cd nss
39   hg id -t -r. | sed 's/^NSS_//;s/_RTM$//;s/_/./g'
42 prepare() {
43   cd nss
45   # https://bugzilla.mozilla.org/show_bug.cgi?id=1382942
46   patch -Np1 -i ../0001-Hack-mpi_x64.s-to-work-with-fno-plt.patch
49 build() {
50   local buildsh_options=(
51     --disable-tests
52     --enable-libpkix
53     --opt
54     --system-nspr
55     --system-sqlite
56     --target ia32
57   )
59   cd nss
60   ./build.sh "${buildsh_options[@]}"
63 package() {
64   local nsprver="$(i686-pc-linux-gnu-pkg-config --modversion nspr)"
65   local libdir=/usr/lib32 includedir=/usr/include/nss
67   sed nss/pkg/pkg-config/nss.pc.in \
68     -e "s,%prefix%,/usr,g" \
69     -e "s,%exec_prefix%,\${prefix},g" \
70     -e "s,%libdir%,$libdir,g" \
71     -e "s,%includedir%,$includedir,g" \
72     -e "s,%NSPR_VERSION%,$nsprver,g" \
73     -e "s,%NSS_VERSION%,$pkgver,g" |
74     install -Dm644 /dev/stdin "$pkgdir$libdir/pkgconfig/nss.pc"
76   ln -s nss.pc "$pkgdir$libdir/pkgconfig/mozilla-nss.pc"
78   install -Dt "$pkgdir$libdir" dist/Release/lib/*.so
80   # Replace built-in trust with p11-kit connection
81   ln -s pkcs11/p11-kit-trust.so "$pkgdir$libdir/p11-kit-trust.so"
82   ln -sf p11-kit-trust.so "$pkgdir$libdir/libnssckbi.so"
85 # vim:set sw=2 sts=-1 et: