upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libabigail / trunk / PKGBUILD
blob029f642692370a1140a34d8bd6a4235437735e81
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
4 pkgname=libabigail
5 pkgver=2.3
6 pkgrel=1
7 pkgdesc='ABI Generic Analysis and Instrumentation Library'
8 arch=('x86_64')
9 license=('Apache')
10 url='https://sourceware.org/libabigail/'
11 depends=(
12   'glibc'
13   'gcc-libs'
14   'binutils'
15   'libxml2'
16   'libelf'
17   'elfutils'
18   'python'
20 makedepends=(
21   'git'
22   'python-sphinx'
24 _commit='cdf3f8e2370b9c393b9fec097a8ef2dde2d45101'
25 source=("git+https://sourceware.org/git/libabigail.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd "$pkgname"
31   git describe --tags | sed 's/^libabigail-//'
34 prepare() {
35   cd "$pkgname"
37   autoreconf -fi
40 build() {
41   cd "$pkgname"
43   ./configure \
44     --prefix=/usr \
45     --enable-bash-completion \
46     --disable-manual \
47     --disable-apidoc \
48     --disable-static
50   make
52   # man pages
53   make -C doc/manuals man
56 check() {
57   cd "$pkgname"
59   make check
62 package() {
63   cd "$pkgname"
65   make DESTDIR="$pkgdir" install
67   # man pages
68   OLDIFS="$IFS"
69   IFS="."
70   pushd doc/manuals/man
72   # delete Fedora-specific man page
73   rm -vf fedabipkgdiff.1
75   for filename in *; do
76     read -ra PART <<< "$filename"
77     section="${PART[1]}"
78     install -vDm644 -t "$pkgdir/usr/share/man/man${section}" "$filename"
79   done
80   IFS="$OLDIFS"
81   unset OLDIFS
82   popd
84   # bash completion
85   cd bash-completion
86   for filename in abicompat abidiff abidw abilint abipkgdiff; do
87     install -vDm644 -t "$pkgdir/usr/share/bash-completion/completions" "$filename"
88   done