upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libafterimage / repos / community-x86_64 / PKGBUILD
blob6aa994a53733c8ef9d25b1cc86325f3c69cc0810
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Mike Sampson <mike at sambodata dot com>
3 # Contributor: Bernhard Walle <bernhard.walle@gmx.de>
5 pkgname=libafterimage
6 pkgver=1.20
7 pkgrel=6
8 pkgdesc="Generic image manipulation library"
9 url="http://www.afterstep.org/afterimage"
10 license=('GPL')
11 depends=('librsvg')
12 arch=('x86_64')
13 source=("https://downloads.sourceforge.net/project/afterstep/libAfterImage/$pkgver/libAfterImage-$pkgver.tar.bz2"
14         libafterimage-libpng15.patch
15         libafterimage-ldflags.patch
16         header-install.patch)
17 sha256sums=('6e233253f4d1dd22dfce9f9a245cc036d814fc99ba7f6732f4e345de62cfe458'
18             'bbf95bcddc4c48dcde88745dc9cb772ca53b625e8e466b9d565e4183ce71dbe3'
19             'a38f2e46bb69f6749c5e48cff60f51fae6bda19d268f0c7f16dfbd74d34d2f64'
20             '6e1c5fd8acbbbc1c83f0ca490f08b7602d37a2295cb4741eef6f3b88fb638203')
22 prepare() {
23   cd libAfterImage-$pkgver
25   # Fix header installation (FS#60246)
26   patch -p1 -i ../header-install.patch
28   # Apply Gentoo's libpng15 patch
29   patch < ../libafterimage-libpng15.patch
31   # Make sure LDFLAGS are passed to lib
32   patch < ../libafterimage-ldflags.patch
35 build() {
36   cd libAfterImage-$pkgver
38   CPPFLAGS="${CPPFLAGS}" \
39   CFLAGS="${CFLAGS}" \
40   CXXFLAGS="${CXXFLAGS}" \
41   LDFLAGS="${LDFLAGS}" \
42   ./configure --prefix=/usr --mandir=/usr/share/man \
43               --enable-sharedlibs --disable-staticlibs
45   # don't run ldconfig
46   sed -i -e 's/`uname`/"hack"/g' Makefile
48   make AR="ar cq"
51 package() {
52   cd libAfterImage-$pkgver
53   make DESTDIR="$pkgdir" install
56 # :mode=shellscript: