upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libemf / trunk / PKGBUILD
blob506b4c55206304f2f5ce2d9b1057831fcdee23dc
1 # Maintainer : Daniel Bermond <dbermond@archlinux.org>
2 # Contributor: lily wilson <hotaru@thinkindifferent.net>
4 pkgname=libemf
5 pkgver=1.0.13
6 pkgrel=2
7 pkgdesc='Library implementation of ECMA-234 API for the generation of enhanced metafiles'
8 arch=('x86_64')
9 url='http://libemf.sourceforge.net/'
10 license=('GPL' 'LGPL')
11 depends=('gcc-libs')
12 source=("https://sourceforge.net/projects/libemf/files/libemf/${pkgver}/${pkgname}-${pkgver}.tar.gz")
13 sha256sums=('74d92c017e8beb41730a8be07c2c6e4ff6547660c84bf91f832d8f325dd0cf82')
15 build() {
16     cd "${pkgname}-${pkgver}"
17     ./configure \
18         --prefix='/usr' \
19         --enable-static='no' \
20         --enable-shared='yes' \
21         --enable-threads \
22         --enable-editing
23     make
26 check() {
27     make -C "${pkgname}-${pkgver}" check
30 package() {
31     make -C "${pkgname}-${pkgver}" DESTDIR="$pkgdir" install