upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libfishsound / repos / community-x86_64 / PKGBUILD
blob25f7c81679ca7171dbd4e308010d088ea138ce6b
1 # Maintainer: David Runge <dave@sleepmap.de>
2 # Contributor: speps <speps at aur dot archlinux dot org>
3 # Contributor: farid <farid at archlinux-br.org>
5 pkgname=libfishsound
6 pkgver=1.0.0
7 pkgrel=5
8 pkgdesc="A simple programming interface that wraps Xiph.Org audio codecs"
9 arch=('x86_64')
10 url="https://www.xiph.org/fishsound/"
11 license=('BSD')
12 depends=('libvorbis' 'speex' 'flac')
13 provides=('libfishsound.so')
14 source=("https://github.com/kfish/${pkgname}/archive/${pkgver}.tar.gz")
15 sha512sums=('52a98489d8cebfd92a1aa18511643108cc818379cf4470fe177c4a27e998f2652e4ffa94a50dd4f8838753714b9001eb8ee9ecb2fff858179f3bc7ffe6d7e35b')
17 prepare() {
18   cd "${pkgname}-${pkgver}"
19   ./autogen.sh
22 build() {
23   cd "${pkgname}-${pkgver}"
24   ./configure --prefix=/usr \
25               --enable-static=no
26   make
29 package() {
30   cd "${pkgname}-${pkgver}"
31   make DESTDIR="$pkgdir/" docdir=./docs install
32   install -vDm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
33   install -vDm 644 {AUTHORS,ChangeLog,NEWS,README} \
34     -t "${pkgdir}/usr/share/doc/${pkgname}"