upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libgpiod / trunk / PKGBUILD
blob155e2660d18f8ecae12fe8ceb3dfab9bb031c642
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Greg Erwin <first name last name 256 at gmail dot com>
4 pkgname=libgpiod
5 pkgver=1.6.4
6 pkgrel=2
7 pkgdesc="C library and tools for interacting with the linux GPIO character device"
8 url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git"
9 arch=('x86_64')
10 license=('LGPL2.1')
11 depends=('python')
12 makedepends=('autoconf-archive' 'doxygen' 'help2man')
13 conflicts=('libgpiod-git')
14 source=("$url/snapshot/$pkgname-$pkgver.tar.gz")
15 sha256sums=('829d4ac268df07853609d67cfc7f476e9aa736cb2a68a630be99e8fad197be0a')
17 build() {
18   cd $pkgname-$pkgver
19   ./autogen.sh \
20     --prefix=/usr \
21     --enable-tools=yes \
22     --enable-bindings-cxx \
23     --enable-bindings-python
24   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
25   make
28 package() {
29   cd $pkgname-$pkgver
30   make DESTDIR="$pkgdir" install