upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libgsystem / repos / community-x86_64 / PKGBUILD
blob308b8b37d1000ed2955aa0e830bd68c59272be0d
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 pkgname=libgsystem
4 pkgver=2015.2+4+gd606bec
5 pkgrel=3
6 pkgdesc='"Copylib" for system service modules using GLib with GCC'
7 url="https://wiki.gnome.org/Projects/LibGSystem"
8 license=(GPL2)
9 arch=(x86_64)
10 depends=(glib2 systemd-libs attr)
11 makedepends=(gobject-introspection gtk-doc systemd git)
12 _commit=d606bec68ddfea78de4b03c3f3568afb71bdc1ce  # master
13 source=("git+https://gitlab.gnome.org/Archive/libgsystem.git#commit=$_commit"
14         "git+https://gitlab.gnome.org/GNOME/libglnx.git")
15 sha256sums=('SKIP'
16             'SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/^v//;s/-/+/g'
23 prepare() {
24   cd $pkgname
26   # Fix header file location
27   sed -i 's|attr/xattr|sys/xattr|g' configure.ac
29   git submodule init
30   git config --local submodule.libglnx.url "$srcdir/libglnx"
31   git submodule update
33   NOCONFIGURE=1 ./autogen.sh
36 build() {
37   cd $pkgname
38   ./configure --prefix=/usr --disable-static --enable-gtk-doc
39   make
42 check() {
43   cd $pkgname
44   make check
47 package() {
48   cd $pkgname
49   make DESTDIR="$pkgdir" install