upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libretro-mgba / trunk / PKGBUILD
blobf0838aecd7f64fa7627210543e3ed7b9e3c3b729
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Duck Hunt <vaporeon@tfwno.gf>
4 pkgname=libretro-mgba
5 pkgver=8797
6 pkgrel=1
7 pkgdesc='Nintendo Game Boy Advance core'
8 arch=(x86_64)
9 url=https://github.com/libretro/mgba
10 license=(custom:MPL2)
11 groups=(libretro)
12 depends=(libretro-core-info)
13 makedepends=(git)
14 _commit=a69c3434afe8b26cb8f9463077794edfa7d5efad
15 source=(libretro-mgba::git+https://github.com/libretro/mgba.git#commit=${_commit})
16 sha256sums=(SKIP)
18 pkgver() {
19   cd libretro-mgba
21   git rev-list --count HEAD
24 build() {
25   make -C libretro-mgba -f Makefile.libretro
28 package() {
29   install -Dm 644 libretro-mgba/mgba_libretro.so -t "${pkgdir}"/usr/lib/libretro/
30   install -Dm 644 libretro-mgba/LICENSE -t "${pkgdir}"/usr/share/licenses/libretro-mgba/
33 # vim: ts=2 sw=2 et: