upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libretro-mupen64plus-next / trunk / PKGBUILD
blob5fa420b281750078da8276059ab1c28db1effb5e
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=libretro-mupen64plus-next
4 pkgver=454
5 pkgrel=1
6 epoch=1
7 pkgdesc='Nintendo 64 core'
8 arch=(x86_64)
9 url=https://github.com/libretro/mupen64plus-libretro-nx
10 license=(GPL2)
11 groups=(libretro)
12 depends=(
13   gcc-libs
14   glibc
15   libgl
16   libpng
17   libretro-core-info
18   minizip
19   xxhash
20   zlib
22 makedepends=(
23   git
24   mesa
25   nasm
27 replaces=(libretro-mupen64plus)
28 _commit=4d270850bd09f8630110da701b73107e45a6e202
29 source=(libretro-mupen64plus-next::git+https://github.com/libretro/mupen64plus-libretro-nx.git#commit=${_commit})
30 sha256sums=(SKIP)
31 options=(!lto)
33 pkgver() {
34   cd libretro-mupen64plus-next
36   git rev-list --count HEAD
39 build() {
40   make \
41     WITH_DYNAREC=x86_64 \
42     HAVE_PARALLEL_RDP=1 \
43     HAVE_PARALLEL_RSP=1 \
44     HAVE_THR_AL=1 \
45     SYSTEM_LIBPNG=1 \
46     SYSTEM_MINIZIP=1 \
47     SYSTEM_XXHASH=1 \
48     SYSTEM_ZLIB=1 \
49     -C libretro-mupen64plus-next
52 package() {
53   install -Dm 644 libretro-mupen64plus-next/mupen64plus_next_libretro.so -t "${pkgdir}"/usr/lib/libretro/
56 # vim: ts=2 sw=2 et: