upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libretro-pcsx-rearmed / trunk / PKGBUILD
blobd460f878c9f55fd37a18de6439908e7edabf65f3
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Johnathan Jenkins <twodopeshaggy@gmail.com>
3 # Contributor: prettyvanilla <prettyvanilla@posteo.at>
4 # Contributor: almostalive <almostalive2003@gmail.com>
6 pkgname=libretro-pcsx-rearmed
7 pkgver=1179
8 pkgrel=1
9 pkgdesc='Sony PlayStation core'
10 arch=('x86_64')
11 url='https://github.com/libretro/pcsx_rearmed'
12 license=('GPL2')
13 groups=('libretro')
14 depends=('glibc' 'zlib')
15 makedepends=('git')
16 source=('libretro-pcsx-rearmed::git+https://github.com/libretro/pcsx_rearmed.git'
17         'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/pcsx_rearmed_libretro.info')
18 sha256sums=('SKIP'
19             'e93b0475d7c6f422ad52af696205409423ddfa449109e76f36a95f17943bfa92')
21 pkgver() {
22   cd libretro-pcsx-rearmed
24   git rev-list --count HEAD
27 build() {
28   cd libretro-pcsx-rearmed
30   make -f Makefile.libretro
33 package() {
34   cd libretro-pcsx-rearmed
36   install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
37   install -m 644 pcsx_rearmed_libretro.so "${pkgdir}"/usr/lib/libretro/
38   install -m 644 ../pcsx_rearmed_libretro.info "${pkgdir}"/usr/share/libretro/info/
41 # vim: ts=2 sw=2 et: