upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / libtiff4 / trunk / PKGBUILD
blobe500bde880baa947cf1c7b63778dd0359d96bd31
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: lorim <lorimz@gmail.com>
4 pkgname=libtiff4
5 pkgver=3.9.7
6 pkgrel=5
7 pkgdesc='Library for manipulation of TIFF images'
8 arch=(x86_64)
9 url=http://www.simplesystems.org/libtiff/
10 license=(custom)
11 depends=(
12   gcc-libs
13   libjpeg-turbo
14   zlib
16 makedepends=(git)
17 source=(
18   git+https://gitlab.com/libtiff/libtiff.git#tag=Release-v${pkgver//./-}
19   libtiff4-soname.patch
21 sha256sums=(
22   SKIP
23   e6246631f6d943715b612b4ddd2279c946ff90c9e8d755fa639e8051a6eb3488
26 prepare() {
27   cd libtiff
29   # Rename 3.9.7 to 4.3.7, 3.6.x was the first release with the unintentional ABI change
30   patch -Np1 -i ../libtiff4-soname.patch
32   ./autogen.sh
35 build() {
36   cd libtiff
38   ./configure \
39     --prefix='/usr'
40   make
43 package() {
44   make DESTDIR="${pkgdir}" -C libtiff install
45   rm -rf "${pkgdir}"/usr/{bin,include,lib/libtiff{,xx}.{a,so},share}
46   install -Dm 644 libtiff/COPYRIGHT -t "${pkgdir}"/usr/share/licenses/libtiff4/
49 # vim: ts=2 sw=2 et: