1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Adrián Pérez de Castro <aperez@igalia.com>
7 pkgdesc='A simple Markdown translator'
9 url='https://kristaps.bsd.lv/lowdown'
11 depends=('glibc' 'libmd')
13 _commit='fc1191eb8785eee2414d3d485109d3ab1e98b0ce'
14 source=("$pkgname::git+https://github.com/kristapsdz/lowdown.git#commit=$_commit")
20 git describe --tags | sed -e 's/^VERSION_//' -e 's/_/./g'
30 # ensure LDFLAGS is passed correctly
31 sed -i "s/^LDFLAGS.*/LDFLAGS = $LDFLAGS/" Makefile.configure
37 make -C "$pkgname" regress
44 make DESTDIR="$pkgdir" \
49 # symlink unversioned to versioned shared library
50 local LIBVER=$(grep "^LIBVER" Makefile | sed "s/.*= //")
51 ln -sf "/usr/lib/liblowdown.so.$LIBVER" "$pkgdir/usr/lib/liblowdown.so"
54 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md