upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / lua-testmore / trunk / PKGBUILD
blob8e7c1148da82aa8d88528573a8f5c0db1af5dc97
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 _project=lua-TestMore
4 pkgbase=${_project,,}
5 _rockname=${pkgbase#lua-}
6 pkgname=("$pkgbase" "lua51-$_rockname" "lua52-$_rockname" "lua53-$_rockname")
7 pkgver=0.3.6
8 _rockrel=1
9 pkgrel=1
10 pkgdesc='A Lua port of the Perl Test::More unit testing framework'
11 arch=(any)
12 url="https://framagit.org/fperrad/$_project"
13 license=(MIT)
14 checkdepends=(lua)
15 _archive="$_project-$pkgver"
16 source=("$url/-/archive/$pkgver/$_archive.tar.bz2")
17 sha256sums=('7724391ad50a32ab55d32171d0901a68a136a404b9f0cd84aa59bf496b6a53b0')
19 check() {
20         cd "$_archive"
21         make check
24 _package() {
25         cd "$_archive"
26         depends=("${pkgname%-*}")
27         make LUAVER="$1" PREFIX=/usr DESTDIR="$pkgdir" install
28         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYRIGHT
31 package_lua-testmore() {
32         _package 5.4
35 package_lua53-testmore() {
36         _package 5.3
39 package_lua52-testmore() {
40         _package 5.2
43 package_lua51-testmore() {
44         _package 5.1