upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / maliit-framework / trunk / PKGBUILD
blob1386c7c5106c41bea1b9830749329f58e9eb0991
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=maliit-framework
4 pkgver=2.3.0
5 pkgrel=1
6 pkgdesc='Core libraries of Maliit and server'
7 arch=(x86_64)
8 url='https://maliit.github.io/'
9 license=(LGPL)
10 depends=(qt5-declarative)
11 makedepends=(cmake qt5-wayland wayland-protocols gtk3 python)
12 optdepends=('qt5-wayland: wayland-shell integration')
13 source=(https://github.com/maliit/framework/archive/$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('bfc23919ac8b960243f85e8228ad7dfc28d557b52182a0b5a2a216a5c6a8057c')
16 build() {
17   cmake -B build -S framework-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -Denable-tests=OFF \
20     -Denable-docs=OFF \
21     -Denable-dbus-activation=ON \
22     -DQT5_PLUGINS_INSTALL_DIR=lib/qt/plugins \
23     -DQT5_MKSPECS_INSTALL_DIR=lib/qt/mkspecs
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build