1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=maliit-framework
6 pkgdesc='Core libraries of Maliit and server'
8 url='https://maliit.github.io/'
10 depends=(qt5-declarative)
11 makedepends=(cmake qt5-wayland wayland-protocols gtk3 python)
12 optdepends=('qt5-wayland: wayland-shell integration')
13 source=(https://github.com/maliit/framework/archive/$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('bfc23919ac8b960243f85e8228ad7dfc28d557b52182a0b5a2a216a5c6a8057c')
17 cmake -B build -S framework-$pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr \
21 -Denable-dbus-activation=ON \
22 -DQT5_PLUGINS_INSTALL_DIR=lib/qt/plugins \
23 -DQT5_MKSPECS_INSTALL_DIR=lib/qt/mkspecs
28 DESTDIR="$pkgdir" cmake --install build