upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / nbtscan / repos / community-x86_64 / PKGBUILD
blobd5d470b8e6f4f27490ad37f0d76b649d73489886
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Sergio Rubio <rubiojr@biondofu.net>
4 pkgname=nbtscan
5 pkgver=1.7.2
6 pkgrel=1
7 pkgdesc='Scan networks searching for NetBIOS information'
8 url='https://github.com/resurrecting-open-source-projects/nbtscan'
9 arch=('x86_64')
10 license=('GPL2')
11 depends=('glibc')
12 makedepends=('git')
13 _commit='e339c81e996e4bda2c9eb5be62ececb9d65c3672'
14 source=("$pkgname::git+$url.git#commit=$_commit")
15 b2sums=('SKIP')
17 pkgver() {
18   cd "$pkgname"
19   git describe --tags | sed 's/^v//'
22 prepare() {
23   cd "$pkgname"
24   autoreconf -fiv
27 build() {
28   cd "$pkgname"
29   ./configure --prefix=/usr
30   make
33 package() {
34   cd "$pkgname"
35   make DESTDIR="$pkgdir" install
36   install -Dm 644 README.md ChangeLog -t "${pkgdir}/usr/share/doc/${pkgname}"
39 # vim: ts=2 sw=2 et: