1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
3 # Contributor: Tyler Dence <tyzoid@archlinux32.org>
4 # Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
6 pkgbase=nextcloud-client
7 # Put config files for libcloudproviders integration in a separate package as
8 # there is no simple way yet to disable it.
9 # See: https://gitlab.gnome.org/World/libcloudproviders/-/issues/17
10 pkgname=(nextcloud-client nextcloud-client-cloudproviders)
12 # Upstream does not provide signed tarballs (yet)
13 # https://github.com/nextcloud/desktop/issues/1510
15 _tag=65a1c7d373a980c2ca9eca3112ec3989a8759ab7
18 url='https://nextcloud.com/'
19 _url=https://github.com/nextcloud/desktop
37 source=("$pkgbase::git+$_url.git?signed#tag=$_tag")
39 A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
40 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
41 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
42 0739B11EDA696A3616666F6AE04221E85C5BB816 # https://github.com/allexzander
43 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
44 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
50 git describe --tags | sed 's/^v//;s/-/+/g'
54 curl -fs https://api.github.com/repos/nextcloud/desktop/git/ref/tags/v$pkgver |
62 # Monkey patch that disables bulk upload capability which causes infinite
63 # loops for many server/client combos. Feature is also disabled by default on
64 # server end in v23.0.3 because it was so problematic. This can abe re-enabled
65 # when underlying bug squashed:
66 # https://github.com/nextcloud/desktop/issues/4241
67 sed -i -e '/bulkupload/s/return _.*;$/return false;/' src/libsync/capabilities.cpp
68 # Disable tests that touch on disabled feature
69 sed -i -e '/SyncEngine/s/^/#/' -e '/Capabilities/s/^/#/' -e '/SecureFileDrop/s/^/#/' test/CMakeLists.txt
75 # bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
76 # Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
78 -DCMAKE_BUILD_TYPE=None \
79 -DCMAKE_INSTALL_PREFIX=/usr \
80 -DWITH_CRASHREPORTER=OFF \
83 -DPLUGINDIR=lib/qt/plugins # Fix vfs plugin install dir https://github.com/nextcloud/desktop/issues/3781#issuecomment-918918320
85 # TODO: fix installation of PDF and HTML documents
86 # WIP at https://github.com/yan12125/desktop/tree/doc-install-path
87 make -C build all doc-man
93 # Tests fail if $TMPDIR is too small; specify an alternative for machines
94 # with a small /tmp partition.
95 # Use UTC as TestCookies is sensitive to the timezone
96 # https://github.com/nextcloud/desktop/blob/v3.2.2/test/testcookies.cpp#L24
97 QT_QPA_PLATFORM=offscreen TMPDIR="$srcdir/tmpdir" TZ=UTC ARGS="--rerun-failed --output-on-failure" make test
100 package_nextcloud-client() {
101 pkgdesc='Nextcloud desktop client'
102 depends=(hicolor-icon-theme
115 optdepends=('kio: integration with Dolphin'
116 'nemo-python: integration with Nemo'
117 'python-nautilus: integration with Nautilus'
118 'python-caja: integration with Caja'
119 'nextcloud-client-cloudproviders: cloudproviders support')
120 backup=('etc/Nextcloud/sync-exclude.lst')
124 make DESTDIR="$pkgdir" install
126 rm -v "$pkgdir"/usr/share/cloud-providers/com.nextcloudgmbh.Nextcloud.ini
127 rm -v "$pkgdir"/usr/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service
128 cd "$pkgdir"/usr/share && rmdir -p cloud-providers dbus-1/services
131 package_nextcloud-client-cloudproviders() {
132 pkgdesc='cloudproviders support for the Nextcloud desktop client'
133 depends=(nextcloud-client)
136 make -C shell_integration/libcloudproviders DESTDIR="$pkgdir" install