upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / obconf-qt / repos / community-x86_64 / PKGBUILD
blob9530450b659c51e25398674dfb4f208c0f2f52b0
1 # Maintainer: Jerome Leclanche <jerome@leclan.ch>
2 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
4 pkgname=obconf-qt
5 pkgver=0.16.2
6 pkgrel=2
7 pkgdesc="Openbox configuration tool. Qt port of ObConf"
8 arch=("x86_64")
9 groups=("lxqt")
10 url="https://github.com/lxqt/$pkgname"
11 license=("GPL2")
12 depends=("hicolor-icon-theme" "openbox" "qt5-x11extras")
13 makedepends=("lxqt-build-tools")
14 source=(
15         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
16         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
18 sha512sums=('bd91a5669f07471966d296b91d78e2a40e2e3640405de2179513457088eb7d6cb063dbfaff623db6f404985734e986b52c1e3155a050f374b7afa58f7d720c0d'
19             'SKIP')
20 validpgpkeys=(
21         "169704C6FB490C6892C7F23C37E0AF1FDA48F373"  # Jerome Leclanche <jerome@leclan.ch>
22         "7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3"  # Alf Gaida <agaida@siduction.org>
23         "19DFDF3A579BD509DBB572D8BE793007AD22DF7E"  # Pedram Pourang <tsujan2000@gmail.com>
27 build() {
28         mkdir -p build
29         cd build
30         cmake "$srcdir/$pkgname-$pkgver" \
31                 -DCMAKE_INSTALL_PREFIX=/usr
32         make
35 package() {
36         cd build
37         make DESTDIR="$pkgdir" install