1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 # Contributor: Baptiste Jonglez <archlinux at bitsofnetworks dot org>
7 pkgdesc="Library for arbitrary-precision integer and rational arithmetic that used to be part of the OCaml core distribution"
9 url="https://github.com/ocaml/num"
11 depends=('ocaml>=4.15.0')
12 makedepends=('ocaml-findlib')
13 options=('!strip' '!makeflags')
14 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ocaml/num/archive/v${pkgver}.tar.gz")
15 sha512sums=('0cc9be8ad95704bb683b4bf6698bada1ee9a40dc05924b72adc7b969685c33eeb68ccf174cc09f6a228c48c18fe94af06f28bebc086a24973a066da620db8e6f')
18 cd "${srcdir}/num-${pkgver}"
23 cd "${srcdir}/num-${pkgver}"
25 local _destdir="${pkgdir}$(ocamlfind printconf destdir)"
26 install -d "${_destdir}/stublibs"
28 make OCAMLFIND_DESTDIR="${_destdir}" findlib-install
31 # vim:set ts=2 sw=2 et: