upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / ocaml-pp / trunk / PKGBUILD
blobdd9aeaeda44700de86710e60a070c41e6d64d455
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 _pkgname='pp'
3 pkgname="ocaml-${_pkgname}"
4 pkgver=1.1.2
5 pkgrel=4
6 pkgdesc="OCaml Pretty printing: a lean alternative to the Format module of the OCaml standard library."
7 arch=('x86_64')
8 url="https://github.com/ocaml-dune/pp"
9 license=('MIT')
10 makedepends=('dune')
11 depends=('glibc' 'ocaml>=4.14.0')
12 options=('!strip')
13 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
14 sha512sums=('8c4dbce6930c62f5cee26ebef907b7b862b03fb57a07a3c6bebc31ee40ef16a6fe2b9450a7fe7016dd48bcf9807009c411f5ea8e587550644495bd7970c63085')
16 build() {
17     cd "${srcdir}/${_pkgname}-${pkgver}"
18     dune build -p "${_pkgname}"
21 package() {
22     cd "${srcdir}/${_pkgname}-${pkgver}"
23     DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir="$(ocamlc -where)"
25     install -dm755 "${pkgdir}/usr/share/"
26     mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
28     install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
29     ln -s /usr/share/doc/pp/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"