1 # Maintainer: Ronald van Haren <ronald.archlinux.org>
2 # Contributor : shining <shiningxc.at.gmail.com>
3 # Contributor : cyberdune <cyberdune@gmail.com>
8 pkgdesc="A high-level language, primarily intended for numerical computations"
10 url="https://www.gnu.org/software/octave/"
12 depends=('fftw' 'curl' 'graphicsmagick' 'glpk' 'hdf5' 'qhull' 'arpack' 'glu' 'ghostscript'
13 'sundials' 'gl2ps' 'qscintilla-qt5' 'libsndfile' 'qt5-tools' 'qrupdate' 'pcre2')
14 makedepends=('gcc-fortran' 'texlive-core' 'suitesparse' 'texinfo' 'gnuplot' 'fltk' 'portaudio' 'jdk-openjdk' 'rapidjson')
15 optdepends=('texinfo: for help-support in octave'
16 'gnuplot: alternative plotting'
17 'portaudio: audio support'
18 'java-runtime: java support'
20 'texlive-bin: for the publish command')
21 source=(https://ftp.gnu.org/gnu/octave/octave-$pkgver.tar.gz{,.sig})
22 options=('!emptydirs')
23 validpgpkeys=('DBD9C84E39FE1AAE99F04446B05F05B75D36644B') # John W. Eaton
24 sha512sums=('987dac6bd6d41316e1bb12f544a4ed8767639e60a117ad7125f2b299bf3dbdb516b6a657fcce5b597759bcaa1f8e49d91bead7a4c43fac73c16cb4818de9c29d'
28 cd ${pkgname}-${pkgver}
30 ./configure --prefix=/usr --libexecdir=/usr/lib \
31 --enable-shared --disable-static \
32 --with-quantum-depth=16
37 cd ${pkgname}-${pkgver}
39 make DESTDIR="${pkgdir}" install
41 # add octave library path to ld.so.conf.d
42 install -d "${pkgdir}/etc/ld.so.conf.d"
43 echo "/usr/lib/${pkgname}/${pkgver}" > "${pkgdir}/etc/ld.so.conf.d/${pkgname}.conf"