1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Jameson Pugh <imntreal@gmail.com>
7 pkgdesc='A C++ library to control Z-Wave Networks via a USB Z-Wave Controller'
9 url=http://www.openzwave.net
23 _tag=890f24b7e88f488eee464ed14c01fbceb276cf2a
25 git+https://github.com/OpenZWave/open-zwave.git#tag=${_tag}
26 openzwave-system-libs.patch
30 56095ee16bb04184b2bf037d7601bc5431c654e1328cd1ad63f1fcb7d6918bcd65ef4ab30ee2c80f3bf3c50e838f5818d23e9d01569e41125e9e68028d021c59
36 git describe --tags | sed 's/^v//'
42 patch -Np1 -i ../openzwave-system-libs.patch
43 sed -e 's/-Werror//' -i cpp/build/Makefile
44 find -name Makefile | xargs sed -e 's/-Wno-format//' -i
48 export CFLAGS="$CFLAGS -Wno-stringop-truncation -Wno-maybe-uninitialized"
49 export CXXFLAGS="$CXXFLAGS -Wno-stringop-truncation -Wno-maybe-uninitialized"
54 make DESTDIR="${pkgdir}" PREFIX=/usr instlibdir=usr/lib/ sysconfdir=etc/openzwave -C open-zwave install