1 # Maintainer: Justin Kromlinger <hashworks@archlinux.org>
5 pkgdesc="A PAM module that provides access control by ip, mac-address, or country-code/region"
9 url='https://github.com/ColumPaget/pam_ihosts'
10 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
11 sha256sums=('0d5952395cdfa3824b4f166862b909cbe4162b43052f747b356285cd8135dab3')
14 sed -e 's|$(CFLAGS)|$(CFLAGS) $(LDFLAGS) $(CPPFLAGS)|;s| -fno-stack-protector ||' -i "pam_ihosts-${pkgver}/Makefile.in"
15 sed '/$(INSTALL) -d $(DESTDIR)$(bindir)/d' -i "pam_ihosts-${pkgver}/Makefile.in"
19 cd "pam_ihosts-${pkgver}"
20 ./configure --prefix=/usr
25 cd "pam_ihosts-${pkgver}"
26 install -Dm644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
27 make DESTDIR="${pkgdir}/" install