upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / pantheon-geoclue2-agent / trunk / PKGBUILD
blobeb1f02446f7c0eb8498ef59cd71c6074c1728fc9
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=pantheon-geoclue2-agent
4 pkgver=1.0.6
5 pkgrel=1
6 pkgdesc='Pantheon Geoclue2 Agent'
7 arch=(x86_64)
8 url=https://github.com/elementary/pantheon-agent-geoclue2
9 license=(GPL3)
10 groups=(pantheon)
11 depends=(
12   geoclue2
13   glibc
14   libgdk-3.so
15   libgio-2.0.so
16   libglib-2.0.so
17   libgobject-2.0.so
18   libgranite.so
19   libgtk-3.so
21 makedepends=(
22   git
23   intltool
24   meson
25   vala
27 _tag=996250b8bb0743a339019dd474f2ef6aeedd724f
28 source=(pantheon-geoclue2-agent::git+https://github.com/elementary/pantheon-agent-geoclue2.git#tag=${_tag})
29 sha256sums=(SKIP)
31 pkgver() {
32   cd pantheon-geoclue2-agent
34   git describe --tags
37 build() {
38   arch-meson pantheon-geoclue2-agent build
39   ninja -C build
42 package() {
43   DESTDIR="${pkgdir}" ninja -C build install
46 # vim: ts=2 sw=2 et: