upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / partclone / trunk / PKGBUILD
blob27ec83b1d874fe6bb2eb3d28672bdc8d32d9f899
1 # Maintainer: Jonathan Steel <jsteel at archlinux.org>
2 # Contrinutor: Dan Serban
3 # Contributor: Franz Burgmann
4 # Contributor: Todd Partridge (Gen2ly)
5 # Contributor: Ivan Sichmann Freitas
7 pkgname=partclone
8 pkgver=0.3.23
9 pkgrel=1
10 pkgdesc="Utilities to save and restore used blocks on a partition"
11 arch=('x86_64')
12 url="https://partclone.org"
13 license=('GPL')
14 depends=('ntfs-3g' 'nilfs-utils')
15 source=($pkgname-$pkgver.tar.gz::https://github.com/Thomas-Tsai/partclone/archive/$pkgver.tar.gz)
16 sha256sums=('55f0d9dc6c66fae05ad5f134f46662d7a2737e25f871943f699d50808482678d')
18 build() {
19   cd $pkgname-$pkgver
20   ./autogen
21   ./configure \
22     --prefix=/usr \
23     --enable-extfs \
24     --enable-fat \
25     --enable-hfsp \
26     --enable-btrfs \
27     --enable-ncursesw \
28     --enable-ntfs \
29     --enable-exfat \
30     --enable-f2fs \
31     --enable-minix \
32     --enable-nilfs2 \
33     --enable-xfs \
34     --sbindir=/usr/bin
35   make
38 package() {
39   cd $pkgname-$pkgver
40   make PREFIX=/usr DESTDIR="$pkgdir" install