upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-file-slurp-tiny / repos / community-any / PKGBUILD
blob480884995d672956afb1da62e16da8853f079751
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 pkgname=perl-file-slurp-tiny
5 pkgver=0.004
6 pkgrel=8
7 pkgdesc="A simple, sane and efficient file slurper"
8 arch=('any')
9 license=('PerlArtistic' 'GPL')
10 options=('!emptydirs')
11 depends=('perl')
12 makedepends=()
13 url='https://search.cpan.org/dist/File-Slurp-Tiny'
14 source=("https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/File-Slurp-Tiny-$pkgver.tar.gz")
15 md5sums=('7575b81543281ea57cdb7e5eb3f73264')
17 build() {
18   cd "$srcdir/File-Slurp-Tiny-$pkgver"
19   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd "$srcdir/File-Slurp-Tiny-$pkgver"
25   PERL_MM_USE_DEFAULT=1
26   make test
29 package() {
30   cd "$srcdir/File-Slurp-Tiny-$pkgver"
31   make install DESTDIR="$pkgdir"
32   find "$pkgdir" -name '.packlist' -o -name '*.pod' -delete