upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-locale-codes / trunk / PKGBUILD
blob882ea24ef5500e08ac74da22990ff89df83017c2
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 pkgname=perl-locale-codes
3 pkgver=3.72
4 pkgrel=1
5 pkgdesc='Distribution of modules to handle locale codes'
6 _dist=Locale-Codes
7 arch=('any')
8 url="https://metacpan.org/release/${_dist}"
9 license=('GPL' 'PerlArtistic')
10 depends=(perl)
11 checkdepends=('perl-test-inter')
12 options=('!emptydirs' purge)
13 source=("https://search.cpan.org/CPAN/authors/id/SBECK/${_dist}-${pkgver}.tar.gz")
14 sha256sums=('5859c087d6f977ee237bc762396adb352b9732d325ccbd2cecacdad63e2f1320')
16 build() {
17   cd "${srcdir}/${_dist}-${pkgver}"
18   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
19   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
20   /usr/bin/perl Makefile.PL
21   make
24 check() {
25   cd "${srcdir}/${_dist}-${pkgver}"
26   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
27   export PERL_MM_USE_DEFAULT=1
28   make test
31 package() {
32   cd "${srcdir}/${_dist}-${pkgver}"
33   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
34   make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"