upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-net-dbus / trunk / PKGBUILD
blobb3947db6d50749f60f8d70b9424d7ed7854dffd4
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Francois Charette <firmicus@gmx.net>
4 pkgname=perl-net-dbus
5 pkgver=1.2.0
6 pkgrel=4
7 pkgdesc="Binding for DBus messaging protocol"
8 arch=('x86_64')
9 url="https://search.cpan.org/dist/Net-DBus"
10 license=('GPL' 'PerlArtistic')
11 depends=('dbus' 'perl-xml-twig')
12 options=('!emptydirs')
13 source=("https://www.cpan.org/authors/id/D/DA/DANBERR/Net-DBus-${pkgver}.tar.gz")
14 sha256sums=('e7a1ac9ef4a1235b3fdbd5888f86c347182306467bd79abc9b0756a64b441cbc')
16 build() {
17   cd  Net-DBus-${pkgver}
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
19   make
22 package() {
23   cd  Net-DBus-${pkgver}
24   make install DESTDIR="$pkgdir"
25   find "$pkgdir" -name '.packlist' -delete
26   find "$pkgdir" -name '*.pod' -delete