upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-net-oauth / trunk / PKGBUILD
blob95a001311a35aea5b27f76689c1ea3b369a83a0e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # CPAN Name  : Net-OAuth
3 # Contributor: Anonymous
4 # Generator  : CPANPLUS::Dist::Arch 1.28
6 pkgname=perl-net-oauth
7 pkgver=0.28
8 pkgrel=12
9 pkgdesc="An implementation of the OAuth protocol"
10 arch=('any')
11 license=('PerlArtistic' 'GPL')
12 options=('!emptydirs')
13 depends=('perl-class-accessor' 'perl-class-data-inheritable' 'perl-digest-hmac' 'perl-digest-sha1' 'perl-uri' 'perl-libwww' 'perl-file-slurp-tiny')
14 makedepends=('perl-module-build')
15 checkdepends=('perl-test-warn')
16 url='https://search.cpan.org/dist/Net-OAuth'
17 source=("https://search.cpan.org/CPAN/authors/id/K/KG/KGRENNAN/Net-OAuth-$pkgver.tar.gz")
18 sha512sums=('b38c3784221bdf56b5b55021cc7e74cf6c5ce47b6743b6fefae9e148ff61d3c1e068aa5829dfed13ffd070e1286ab0d743e2f7b7c900f5fd8cf78f788cff70c4')
20 build() {
21   cd "$srcdir/Net-OAuth-$pkgver"
22   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
23   make
26 check() {
27   cd "$srcdir/Net-OAuth-$pkgver"
28   PERL_MM_USE_DEFAULT=1
29   make test
32 package() {
33   cd "$srcdir/Net-OAuth-$pkgver"
34   make install DESTDIR="$pkgdir"
35   find "$pkgdir" -name '.packlist' -o -name '*.pod' -delete