upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-ntlm / trunk / PKGBUILD
blobc3dafdb83ee3990417e9ced9102e24830d5a041c
1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
2 # Contributor: Eduardo Leggiero <https://www.leggiero.uk/>
4 pkgname=perl-ntlm
5 pkgver=1.09
6 pkgrel=7
7 pkgdesc='Perl/CPAN module NTLM'
8 arch=('any')
9 url='https://metacpan.org/release/NTLM'
10 license=('GPL')
11 depends=('perl')
12 makedepends=('perl-digest-hmac')
13 options=('!emptydirs' purge)
14 source=("https://cpan.metacpan.org/authors/id/N/NB/NBEBOUT/NTLM-${pkgver}.tar.gz")
15 b2sums=('dbf8f4497f2e57c72ad6a5dc6ff21e3cba35bdeee1ebccfc9efecb04a9808b7f3fb929c055acb7038f2990e6ef6a553a09573af70b065ffc74a72fba223e2fae')
17 build() {
18   cd NTLM-${pkgver}
19   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
20   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
21   perl Makefile.PL
22   make
25 check() {
26   cd NTLM-${pkgver}
27   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
28   export PERL_MM_USE_DEFAULT=1
29   make test
32 package(){
33   cd NTLM-${pkgver}
34   unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
35   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"