upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-par-dist / trunk / PKGBUILD
blob74352433f3593ed8a279b77a3526ea66df14e850
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: TDY <tdy@gmx.com>
3 # Contributor: François Charette <firmicus ατ gmx δοτ net>
5 pkgname=perl-par-dist
6 pkgver=0.51
7 pkgrel=3
8 pkgdesc="Perl bindings to create and manipulate PAR distributions"
9 arch=('any')
10 url="https://search.cpan.org/dist/PAR-Dist/"
11 license=('GPL' 'PerlArtistic')
12 depends=('perl')
13 options=('!emptydirs')
14 source=("https://search.cpan.org/CPAN/authors/id/R/RS/RSCHUPP/PAR-Dist-$pkgver.tar.gz")
15 sha512sums=('4c06ff54dfa8f3dc4766b60c45337b3cf80b32ec6bcc49d7e5a4786e0533e495f6215b257100fa5aae50f12e01a8b3d7144254d8706019c50ff115915f0fcb41')
17 build() {
18   cd "$srcdir/PAR-Dist-$pkgver"
19   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd "$srcdir/PAR-Dist-$pkgver"
25   make test
28 package() {
29   cd "$srcdir/PAR-Dist-$pkgver"
30   make install DESTDIR="$pkgdir"