upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-params-util / trunk / PKGBUILD
blob20eb1e7ee05070e02820b9825abd0b6c6c7032b2
1 # Maintainer: Jonathan Steel <jsteel at aur.archlinux.org>
2 # Contributor: Justin Davis (juster) <jrcd83@gmail.com>
4 pkgname=perl-params-util
5 pkgver=1.102
6 pkgrel=3
7 pkgdesc='Simple, compact and correct param-checking functions'
8 arch=('x86_64')
9 url="https://metacpan.org/release/Params-Util"
10 license=('PerlArtistic' 'GPL')
11 depends=('perl')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/R/RE/REHSACK/Params-Util-$pkgver.tar.gz")
14 sha512sums=('e2587b62545cf0572cc8f719ea8e5411d710789c3cbcab4038c5b01f86073a010d32191551f6aeea1bdae22d49e7d34358250b4e7ece9f261a598854af187194')
16 build() {
17   cd "$srcdir/Params-Util-$pkgver"
18   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
19   unset PERL5LIB PERL_MM_OPT
20   /usr/bin/perl Makefile.PL
21   make
24 check() {
25   cd "$srcdir/Params-Util-$pkgver"
26   export PERL_MM_USE_DEFAULT=1
27   unset PERL5LIB
28   make test
31 package() {
32   cd "$srcdir/Params-Util-$pkgver"
33   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
34   find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
37 # Local Variables:
38 # mode: shell-script
39 # sh-basic-offset: 2
40 # End:
41 # vim:set ts=2 sw=2 et: