upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-path-finddev / trunk / PKGBUILD
blob54517b240c2c8055527ddeef59e4abea75db5bfd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-path-finddev
4 pkgver=0.5.3
5 pkgrel=5
6 pkgdesc="Find a development path somewhere in an upper hierarchy"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/Path-FindDev"
10 depends=('perl-class-tiny' 'perl-path-isdev' 'perl-path-tiny' 'perl-sub-exporter')
11 options=('!emptydirs')
12 source=("https://cpan.metacpan.org/authors/id/K/KE/KENTNL/Path-FindDev-v$pkgver.tar.gz")
13 sha512sums=('dd7a6a05f9e21c45a5ef25b3e2598a8f769a2ab3ef24ddb8e918b17a0f025bc5ba5b23fecf832911b7003de6cdaceb0e4a8c1139b4e23b080920739604e37bf6')
15 build() {
16   cd Path-FindDev-v$pkgver
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd Path-FindDev-v$pkgver
23   make test
26 package() {
27   cd Path-FindDev-v$pkgver
28   make DESTDIR="$pkgdir" install