upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-proc-simple / trunk / PKGBUILD
blob162250345534c786754ce09591ed52b6764eb449
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
3 # Generator  : CPANPLUS::Dist::Arch 1.28
5 pkgname=perl-proc-simple
6 pkgver=1.32
7 pkgrel=8
8 pkgdesc="launch and control background processes"
9 arch=('any')
10 license=('PerlArtistic' 'GPL')
11 options=('!emptydirs')
12 depends=('perl')
13 url='https://search.mcpan.org/dist/Proc-Simple'
14 source=("https://search.mcpan.org/CPAN/authors/id/M/MS/MSCHILLI/Proc-Simple-$pkgver.tar.gz")
15 sha512sums=('bb054a7ee2ee36abd2e807b24f5a316902008645e940a9ac3248bfbf2d9ef1a7d0797f14143fa96b09481ec6485a340ea2789929e05da07dd487a76780e1502d')
16 _distdir="Proc-Simple-$pkgver"
18 build() {
19   cd "$srcdir/$_distdir"
20   perl Makefile.PL INSTALLDIRS=vendor
21   make
24 check() {
25   cd "$srcdir/$_distdir"
26   make test
29 package() {
30   cd "$srcdir/$_distdir"
31   make install DESTDIR="$pkgdir"
34 # vim:set ts=2 sw=2 et: