upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-test-mocktime / trunk / PKGBUILD
blobdcfbcd8abd14e68953082fb2d9caa6f44f3202d3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-test-mocktime
4 pkgver=0.17
5 pkgrel=6
6 pkgdesc="Replaces actual time with simulated time"
7 arch=('any')
8 license=('PerlArtistic' 'GPL')
9 options=('!emptydirs')
10 depends=('perl')
11 url='https://search.cpan.org/dist/Test-MockTime'
12 source=("https://search.cpan.org/CPAN/authors/id/D/DD/DDICK/Test-MockTime-$pkgver.tar.gz")
13 sha512sums=('ad73be430e3a483a61209bacf4bfa170d6eec6597d3c0efcf5de167f9c129fbf656581dcdceeba88bd98e530371db2542894ded793f9d46e4155c612e2b7cac5')
15 build() {
16   cd "$srcdir/Test-MockTime-$pkgver"
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd "$srcdir/Test-MockTime-$pkgver"
23   make test
26 package() {
27   cd "$srcdir/Test-MockTime-$pkgver"
28   make DESTDIR="$pkgdir" install
31 # vim:set ts=2 sw=2 et: