upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / perl-text-diff / trunk / PKGBUILD
blob48b1742fe3688fae26a78ca3026c53f558c0d260
1 # Contributor: Firmicus <francois.archlinux.org>  
3 pkgname=perl-text-diff
4 pkgver=1.45
5 pkgrel=2
6 pkgdesc="Perform diffs on files and record sets "
7 arch=('any')
8 url="https://search.cpan.org/dist/Text-Diff"
9 license=('GPL' 'PerlArtistic')
10 depends=('perl-algorithm-diff>=1.1900')
11 options=('!emptydirs')
12 source=(https://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Text-Diff-$pkgver.tar.gz)
13 sha256sums=('e8baa07b1b3f53e00af3636898bbf73aec9a0ff38f94536ede1dbe96ef086f04')
15 build() {
16   cd "$srcdir"/Text-Diff-${pkgver}
17   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor  
18   make 
20 package() {
21   cd "$srcdir"/Text-Diff-${pkgver}
22   make install DESTDIR="$pkgdir" 
23   find "$pkgdir" -name '.packlist' -delete
24   find "$pkgdir" -name '*.pod' -delete