upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / physfs / trunk / PKGBUILD
blobe23954417dbcbd4aff6f22d5dc4a4da61eed3b88
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Eric Bélanger <eric@archlinux.org>
4 pkgname=physfs
5 pkgver=3.2.0
6 pkgrel=1
7 pkgdesc='Portable and flexible I/O abstraction for archives'
8 arch=(x86_64)
9 url='https://icculus.org/physfs'
10 license=(ZLIB)
11 makedepends=(cmake doxygen git ninja)
12 source=('git+https://github.com/icculus/physfs#commit=eb3383b532c5f74bfeb42ec306ba2cf80eed988c') # tag: release-3.2.0
13 b2sums=(SKIP)
15 build() {
16   cmake \
17     -B build \
18     -D CMAKE_BUILD_TYPE=Release \
19     -D CMAKE_INSTALL_PREFIX=/usr \
20     -D PHYSFS_BUILD_TEST=OFF \
21     -G Ninja \
22     -S $pkgname
23   ninja -C build all docs
26 package() {
27   DESTDIR="$pkgdir" ninja -C build install
28   install -d "$pkgdir/usr/share/"{doc/physfs,man/man3}
29   install -m644 build/docs/html/* "$pkgdir/usr/share/doc/physfs"
30   install -m644 build/docs/man/man3/* "$pkgdir/usr/share/man/man3"
31   for name in Deinit Free Init Malloc Realloc author deprecated description \
32     extension major minor opaque patch remove url; do
33     mv "$pkgdir/usr/share/man/man3/"{,PHYSFS_}$name.3
34   done
35   install -D -m644 $pkgname/LICENSE.txt \
36     "$pkgdir/usr/share/licenses/$pkgname/LICENSE"