1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
3 # Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
8 pkgdesc='A pipe-like SOCKS5 tunnel system'
10 url="https://github.com/pipesocks/pipesocks"
12 depends=('qt5-declarative' 'qt5-quickcontrols2' 'libsodium')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/pipesocks/pipesocks/archive/$pkgver.tar.gz")
14 sha512sums=('2524432528d46a24d2a31446a6fee50d3192b6d56a8ac9fd7055ef67614975e6378f59df48d9fd6113a3e09536a3149ca1069bec0f1db7f071db475e88b160c3')
17 cd pipesocks-$pkgver/pipesocks
19 # Disable transparent - dunno why it shows as completely transparent :/
20 sed -i 's/,0.8/,1/' Main.qml
22 # QSystemTrayIcon is in QtWidgets, so we need QApplication to initialize
23 sed -i 's/QGuiApplication/QApplication/' *.cpp *.h
27 cd pipesocks-$pkgver/pipesocks
33 cd pipesocks-$pkgver/pipesocks
34 install -Dm755 pipesocks "$pkgdir"/usr/bin/pipesocks