upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / pipesocks / trunk / PKGBUILD
blobf568a3f435d6e0587daa874955b09163c9a57ca6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
3 # Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
5 pkgname=pipesocks
6 pkgver=2.3
7 pkgrel=4
8 pkgdesc='A pipe-like SOCKS5 tunnel system'
9 arch=('x86_64')
10 url="https://github.com/pipesocks/pipesocks"
11 license=('GPL3')
12 depends=('qt5-declarative' 'qt5-quickcontrols2' 'libsodium')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/pipesocks/pipesocks/archive/$pkgver.tar.gz")
14 sha512sums=('2524432528d46a24d2a31446a6fee50d3192b6d56a8ac9fd7055ef67614975e6378f59df48d9fd6113a3e09536a3149ca1069bec0f1db7f071db475e88b160c3')
16 prepare() {
17   cd pipesocks-$pkgver/pipesocks
19   # Disable transparent - dunno why it shows as completely transparent :/
20   sed -i 's/,0.8/,1/' Main.qml
22   # QSystemTrayIcon is in QtWidgets, so we need QApplication to initialize
23   sed -i 's/QGuiApplication/QApplication/' *.cpp *.h
26 build() {
27   cd pipesocks-$pkgver/pipesocks
28   qmake-qt5 PREFIX=/usr
29   make
32 package() {
33   cd pipesocks-$pkgver/pipesocks
34   install -Dm755 pipesocks "$pkgdir"/usr/bin/pipesocks