upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / pixiewps / trunk / PKGBUILD
blobc0509514411679be0d45d6bb2268309908dda32f
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Mitch Bigelow <ipha00@gmail.com>
4 pkgname=pixiewps
5 pkgver=1.4.2
6 pkgrel=3
7 pkgdesc='Offline bruteforce of the WPS pin exploiting the low or non-existing entropy of some APs'
8 url='https://github.com/wiire/pixiewps'
9 arch=('x86_64')
10 license=('GPL3')
11 depends=('glibc' 'openssl')
12 optdepends=('reaver: authentication session key support'
13             'bully: authentication session key support')
14 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/wiire-a/pixiewps/archive/v${pkgver}.tar.gz)
15 sha512sums=('e64b29b0ab46a768d7e76904b8be61a6c050ccd97da47dc43406a0247b728a521f88f10c8b3bdddfa87dca30955337782c91b3c128a578cbefdcceba811ad64f')
17 build() {
18   cd ${pkgname}-${pkgver}
19   make OPENSSL=1 CFLAGS="${CFLAGS}"
22 package() {
23   cd ${pkgname}-${pkgver}
24   make DESTDIR="${pkgdir}" PREFIX=/usr install
25   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
26   install -Dm 644 pixiewps.1 -t "${pkgdir}/usr/share/man/man1"
29 # vim: ts=2 sw=2 et: