upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / plank / trunk / PKGBUILD
blob5cb637f3ea6fb102d0877ec720078f630e449afe
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
3 # Contributor: dcelasun <dcelasun@gmail.com>
5 pkgname=plank
6 pkgver=0.11.89
7 pkgrel=4
8 pkgdesc='Elegant, simple, clean dock'
9 arch=(x86_64)
10 url=https://launchpad.net/plank
11 license=(GPL3)
12 depends=(
13   atk
14   bamf
15   cairo
16   gdk-pixbuf2
17   glib2
18   glibc
19   gnome-menus
20   gtk3
21   libgee
22   libwnck3
23   libx11
24   libxfixes
25   libxi
26   pango
28 makedepends=(
29   git
30   gnome-common
31   intltool
32   vala
34 source=(git+https://github.com/ricotz/plank.git#tag=${pkgver})
35 sha256sums=(SKIP)
37 prepare() {
38   cd plank
39   git cherry-pick -n 5967798a47ba8835ae100c01a8d647d2f9a2412f
40   sed 's/0.19.6/0.20/' -i configure.ac
41   NOCONFIGURE=1 ./autogen.sh
44 pkgver() {
45   cd plank
46   git describe --tags
49 build() {
50   cd plank
51   ./configure \
52     --prefix=/usr \
53     --sysconfdir=/etc \
54     --disable-apport
55   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
56   make
59 package() {
60   make DESTDIR="${pkgdir}" -C plank install
63 # vim: ts=2 sw=2 et: