1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Bhushan Shah <bshah@kde.org>
4 pkgname=plasma-maliit-framework
6 _commit=0e273b3863d3435cfc486cf1aa9dcecfad1e180d
8 pkgdesc="Framework for Maliit integration with Plasma"
11 url="https://cgit.kde.org/plasma-maliit-framework.git"
12 depends=('qt5-declarative' 'kwayland' 'karchive')
14 source=("git+https://github.com/KDE/plasma-maliit-framework.git#commit=$_commit")
24 CONFIG+=qt5-inputcontext \
25 CONFIG+=nohwkeyboard \
26 CONFIG+=enable-dbus-activation \
29 ../plasma-maliit-framework
35 make install INSTALL_ROOT="$pkgdir/"
36 mv "$pkgdir"/usr/include/maliit/framework/maliit/* "$pkgdir"/usr/include/maliit/
37 mv "$pkgdir"/usr/include/maliit/plugins/maliit/plugins/* "$pkgdir"/usr/include/maliit/plugins/
38 rm -r "$pkgdir"/usr/include/maliit/plugins/maliit "$pkgdir"/usr/include/maliit/framework