upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / plasma-maliit-plugins / trunk / PKGBUILD
blobf5fb617e8ab42787e53097f0dc0a3ec3cdd1cfcd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Bhushan Shah <bshah@kde.org>
4 pkgname=plasma-maliit-plugins
5 pkgver=0.99.0.20150710
6 _commit=0b5cdb59bd1b6bc1f88d815e8b97750fdd014993
7 pkgrel=2
8 pkgdesc="Plasma Integration for Maliit virtual keyboard"
9 arch=('x86_64')
10 license=('GPL')
11 url="https://cgit.kde.org/plasma-maliit-plugins.git"
12 depends=('plasma-maliit-framework')
13 makedepends=('git')
14 source=("git+https://github.com/KDE/plasma-maliit-plugins.git#commit=$_commit")
15 sha512sums=('SKIP')
17 prepare() {
18   mkdir -p build
21 build() {
22   cd build
23   qmake -makefile \
24     CONFIG+=nohwkeyboard \
25     CONFIG+=notests \
26     CONFIG+=nodoc \
27     ../plasma-maliit-plugins
28   make
31 package() {
32   cd build
33   make install INSTALL_ROOT="$pkgdir/"