upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / purple-skypeweb / trunk / PKGBUILD
blob337ebf8990f5250e3570b1876270b83ec706c6ac
1 # Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
2 # Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
3 # Contributor: Colin Arnott
5 pkgname=purple-skypeweb
6 _pkgname=skypeweb
7 _parentname=skype4pidgin
8 pkgver=1.7
9 pkgrel=4
10 arch=('x86_64')
11 license=('GPL3')
12 pkgdesc="SkypeWeb Plugin for Pidgin"
13 url="https://github.com/EionRobb/skype4pidgin/tree/master/skypeweb"
14 depends=('libpurple' 'json-glib')
16 source=("$pkgname-$pkgver.tar.gz"::"https://github.com/EionRobb/$_parentname/archive/$pkgver.tar.gz"
17         "make-the-opid-stage-optional.patch")
18 sha256sums=('e504d4c4807a45aa6ab1c62509c2f31a97952bbf2f0501428fd32a885b2ad84e'
19             'a2b1c581bb287a456ba1926d877b174de0fc022dc350ddef4bed03e49d073de9')
21 prepare() {
22     cd "$srcdir/$_parentname-$pkgver"
23     # Make the opid stage optional
24     # https://github.com/EionRobb/skype4pidgin/commit/91b0d8a6114c66bf291ca8142c2ee2df12d3923a
25     patch -Np1 -i ../make-the-opid-stage-optional.patch
28 build() {
29     cd "$srcdir/$_parentname-$pkgver/$_pkgname"
30     make
33 package() {
34     cd "$srcdir/$_parentname-$pkgver/$_pkgname"
35     make DESTDIR="$pkgdir" install