upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / pyprof2calltree / trunk / PKGBUILD
blobec91560e194bfd58d1108921db4637c39e4acb5b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
3 # Contributor: Brecht Machiels <brecht at mos6581 dot org>
5 pkgname=pyprof2calltree
6 pkgver=1.4.5
7 pkgrel=8
8 pkgdesc="Help visualize profiling data from cProfile with kcachegrind"
9 url="https://pypi.python.org/pypi/pyprof2calltree/"
10 arch=('any')
11 license=('BSD')
12 depends=('python')
13 makedepends=('python-setuptools')
14 source=("https://pypi.io/packages/source/p/pyprof2calltree/pyprof2calltree-$pkgver.tar.gz")
15 sha512sums=('9ad50a5c00881cbd8c361726b16fcb407c899c8dfe201769eddf10c3541531491f49cd5a08658b70d1e85e4c00d9a89801d600ab4f7d9906d357a0de82784f9e')
17 prepare() {
18   sed -n '/# Copyright/,/# THE SOFTWARE\./p' pyprof2calltree-$pkgver/pyprof2calltree.py > LICENSE
21 build() {
22   cd "$srcdir"/pyprof2calltree-$pkgver
23   python setup.py build
26 package() {
27   cd pyprof2calltree-$pkgver
28   python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
29   install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE