upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / pystring / repos / community-x86_64 / PKGBUILD
blob8c18fed44bc459e42901aa9c4e463cfbcd2e75d8
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
3 # Contributor: Alexey Pavlov <alexpux@gmail.com>
5 pkgname=pystring
6 pkgver=1.1.4
7 pkgrel=1
8 arch=('x86_64')
9 pkgdesc="C++ functions matching the interface and behavior of python string methods with std::string"
10 url="https://github.com/imageworks/pystring"
11 license=('BSD')
12 depends=('gcc-libs')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/imageworks/pystring/archive/v$pkgver.tar.gz"
14         "$pkgname-fix-makefile.patch::https://github.com/imageworks/pystring/pull/42.patch")
15 sha512sums=('9c0460fea67885492f9b0d29a9ba312d960fd5e43577cdcfd47faf04397ff4b7e456ed68f1948b923d2f63f9922d576b93e4ca1a27376bcb6d29c683828acb01'
16             '2e8dea3c0e3a90fbb1ae4891e2aa59f10996825b10daf90476fec8c205e36f575ef9bec897ef5126fab957ca081f7b9cf1cd04e4ebdb3636496fb38b978f560c')
18 prepare() {
19   cd $pkgname-$pkgver
20   patch -p1 -i "$srcdir/$pkgname-fix-makefile.patch"
23 build() {
24   cd $pkgname-$pkgver
25   make
28 package() {
29   cd $pkgname-$pkgver
30   DESTDIR="$pkgdir" make install
32   install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"/LICENSE