upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-aiohttp-socks / trunk / PKGBUILD
blob9a9a8c8dba2a5a55a4c5c794c00c7122b196384e
1 # Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
2 # Maintainer: Jonas Witschel <diabonas@archlinux.org>
4 pkgname=python-aiohttp-socks
5 pkgver=0.8.0
6 _tag=9fadc42fe6fb7d4050f5fdcc0aea0f7e5be6ffae # git rev-parse "v$pkgver"
7 pkgrel=1
8 pkgdesc="SOCKS proxy connector for aiohttp. SOCKS4(a) and SOCKS5 are supported."
9 arch=('any')
10 url="https://github.com/romis2012/aiohttp-socks/"
11 license=('Apache')
12 depends=('python' 'python-aiohttp' 'python-python-socks')
13 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
14 checkdepends=('python-flask' 'python-pytest' 'python-pytest-asyncio' 'python-trustme' 'python-anyio' 'python-tiny-proxy')
15 source=("git+https://github.com/romis2012/aiohttp-socks.git?signed#tag=$_tag")
16 sha256sums=('SKIP')
17 validpgpkeys=('706A8935FED55F3BFB7C188B5EEAD7400A5D80ED') # Roman Snegirev (maintainer)
19 pkgver() {
20         cd "${pkgname//python-}"
21         git describe | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
24 build() {
25     cd "${pkgname//python-}"
26     python -m build --wheel --no-isolation
29 check() {
30     cd "${pkgname//python-}"
31     pytest
34 package() {
35     cd "${pkgname//python-}"
36     python -m installer --destdir="$pkgdir" dist/*.whl