1 # Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
2 # Maintainer: Jonas Witschel <diabonas@archlinux.org>
4 pkgname=python-aiohttp-socks
6 _tag=9fadc42fe6fb7d4050f5fdcc0aea0f7e5be6ffae # git rev-parse "v$pkgver"
8 pkgdesc="SOCKS proxy connector for aiohttp. SOCKS4(a) and SOCKS5 are supported."
10 url="https://github.com/romis2012/aiohttp-socks/"
12 depends=('python' 'python-aiohttp' 'python-python-socks')
13 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
14 checkdepends=('python-flask' 'python-pytest' 'python-pytest-asyncio' 'python-trustme' 'python-anyio' 'python-tiny-proxy')
15 source=("git+https://github.com/romis2012/aiohttp-socks.git?signed#tag=$_tag")
17 validpgpkeys=('706A8935FED55F3BFB7C188B5EEAD7400A5D80ED') # Roman Snegirev (maintainer)
20 cd "${pkgname//python-}"
21 git describe | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
25 cd "${pkgname//python-}"
26 python -m build --wheel --no-isolation
30 cd "${pkgname//python-}"
35 cd "${pkgname//python-}"
36 python -m installer --destdir="$pkgdir" dist/*.whl