upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-apispec / trunk / PKGBUILD
blobc88ea3a39557dbcbf17dba8d0bde89ab5a940358
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-apispec
4 pkgver=6.0.2
5 pkgrel=2
6 pkgdesc="A pluggable API specification generator. Currently supports the OpenAPI Specification."
7 url="https://github.com/marshmallow-code/apispec"
8 license=('MIT')
9 arch=('any')
10 depends=('python-packaging')
11 optdepends=('python-yaml: for yaml support'
12             'python-prance: for validation'
13             'python-openapi-spec-validator: for validation')
14 makedepends=('python-setuptools')
15 checkdepends=('python-pytest-runner' 'python-tornado' 'python-bottle' 'python-marshmallow'
16               'python-flask' 'python-prance' 'python-yaml'
17               'python-openapi-spec-validator')
18 source=("$pkgname-$pkgver.tar.gz::https://github.com/marshmallow-code/apispec/archive/$pkgver.tar.gz")
19 sha512sums=('aa5e2cc41d5b3c4555da929819135df30192e6f6ff08518d62674495f0d28c14e51a0aa111b289e5f9d7205f821c1fd4e28b914899ea3e15b3e20f6052258117')
21 build() {
22   cd apispec-$pkgver
23   python setup.py build
26 check() {
27   cd apispec-$pkgver
28   python setup.py pytest
31 package() {
32   cd apispec-$pkgver
33   python setup.py install --root="$pkgdir" --optimize=1
34   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE