upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-biscuits / trunk / PKGBUILD
bloba875c71edc2576c016dd110fcbb53aea0f28e307
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-biscuits
4 pkgver=0.3.0
5 pkgrel=2
6 pkgdesc="Fast and tasty cookies handling"
7 url="https://github.com/pyrates/biscuits"
8 license=('MIT')
9 arch=('x86_64')
10 depends=('python')
11 makedepends=('cython' 'python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/pyrates/biscuits/archive/$pkgver.tar.gz")
14 sha512sums=('75650cef8512301ffef29fd6b55f200a299812739038b43f470885e59a038ed66beeb851312f9e5a2b1a448d0bae15d68ead11bce0563632c559177b72688f95')
16 build() {
17   cd biscuits-$pkgver
18   make compile
21 check() {
22   cd biscuits-$pkgver
23   python setup.py pytest
26 package() {
27   cd biscuits-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1